• Help Center
  • “No valid plugins” InstaShow WordPress plugin installation error

“No valid plugins” InstaShow WordPress plugin installation error

There is an error that comes up sometimes when our customers are trying to install InstaShow WordPress plugin:

The package could not be installed. No valid plugins were found.

This mistake is easy to make, and fortunately, it is as easy to fix. When you download the plugin, you get the full product zip. It contains the plugin itself, as well as the docs and the changelog. The mistake happens when you try to install this zip archive. To do everything right, you need to get the plugin installer zip instead of the whole product zip. There are two ways to do this:

  1. First, unzip the full product zip.

    As you can see from the screenshot, there are different files there, the folder with the plugin itself, and the plugin installer zip that you have to upload to WordPress. When installing InstaShow, you’ll need elfsight-instashow.zip.

  2. The other way is to download Installable WordPress file from https://codecanyon.net/downloads. Go to this link, log in if necessary and select InstaShow. Then click Download button, and select Installable WordPress file only. After you have downloaded the zip, you can use it to install InstaShow plugin to your WordPress website!